OBD Trackers

Incident Report for Axscend Limited

Resolved

We believe this should now be resolved and devices should begin to update over the next few hours. Apologies for any inconvenience caused.
Posted Jun 16, 2026 - 17:16 BST

Identified

We've identified an issue preventing a small number of OBD trackers from updating on the platform, and are developing a solution to recover them. We believe this will be a remote fix, and should be available shortly. We apologies for any inconvenience caused during this time.
Posted Jun 16, 2026 - 16:54 BST
This incident affected: Asset Tracking.