We will be undergoing scheduled maintenance during this time.
Posted May 15, 2025 - 17:33 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted May 15, 2025 - 17:32 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted May 24, 2025 - 21:00 BST
Scheduled
Saturday 24th May the Axscend web portal and its related services will be unavailable through the night and into the early morning whilst we perform some critical system maintenance on our infrastructure. No data will be lost during this period, but trackers may not update until later on the Sunday. We apologise for any inconvenience caused during this time. If there are any issues with this maintenance for your business, please contact our support team at support@axscend.com to discuss options further.
Posted May 06, 2025 - 16:23 BST
This scheduled maintenance affects: Axscend Portal, Asset Tracking, Axscend API, and Axscend Mobile Apps.