Error adding assets to the system

Incident Report for Axscend Limited

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 13:52 BST

Identified

We have had reports of an error occurring when adding new assets to the system for some users. We have identified the root cause and a fix is currently deploying, and should be available before 1.30pm. We apologies for any inconvenience caused.
Posted Jun 05, 2026 - 12:57 BST
This incident affected: Axscend Portal.