Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 07, 2025 - 17:00 BST
Scheduled
We need to perofrm a further system update to the platofrm which will require it to become unavailable for a small period of time. We expect the portal and related systems to be unavailable for ~10-20 minutes whilst this update is applied. We apologise for any inconvenience caused.
Posted Aug 06, 2025 - 15:58 BST
This scheduled maintenance affected: Axscend Portal, Asset Tracking, Axscend API, and Axscend Mobile Apps.